読者です 読者をやめる 読者になる 読者になる

面白きことは良きことなり

拙く未熟なiOSエンジニアの備忘録と戯言

guard構文の知られていない記述

Swift2.0から導入されたnilチェックとアンラップが同時に行えるguard構文のよくある形は下記書き方だと思う。

guard let fuga = hoge else {
    return
}

ただいつも書いてて思うのが、hogeをアンラップするのに新しい変数名を考えなければいけないことが気になる。

しかし!!

実は、特に変数名を変える必要がなかったりする。

guard let hoge = hoge else {
    return
}

この書き方でエラーにならないし、guard後にはアンラップした状態でhogeをそのまま使える。

あまりこういう記述を見かけないけど、同じ変数な以上扱いや見易さはこちらの方が断然良いと思う。
コーディング規約次第なところはあるけど。